It is currently Fri Sep 21, 2018 7:32 pm

All times are UTC [ DST ]





Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: The mrs' pug 106 troubles
PostPosted: Sat Jan 08, 2011 1:56 pm 
Offline
Non-Member

Joined: Sun Jan 24, 2010 10:27 am
Posts: 16
Hi, sorry dont post much at all but was hoping someone here may be able to help.
My girlfriends got her first car about a year a go, Y reg peugeot 106 1.1ltr. Its been fine until last week, the engine management light came on and the car started to misfire, lose power and make a funny noise.
We had it booked in to the garage today and when we tried starting it, it didnt want to turn over. Took about half an hour or trying before it started up.
Whilst we were doing this, all the dials, rev speedo etc where all as normal, i.e. rev needle was moving as the car was trying to start, but when it did start, all the needles (rev, speed and fuel) froze where they were.

We drove it to the garage and it was a coil pack, which was replaced and the car is now fine, however the needles are still stuck as they were. The garage were pushed for time and said it was unrelated and without looking properly they couldnt say what caused it.
So, does anyone here know!?
I dont really want to take it in the garage again if its a simple fix.
Any help would be hugely appreciated,
cheers


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron